S
Sealbook
Search
Categories
Countries
Open source
Blog
Validate idea
Compare
0
AI advisor
EN
ES
Sealbook
/
Open source
/ TypeScript
Top TypeScript projects on GitHub
6,528 TypeScript repositories with 1,000+ stars, ranked by stars.
Repository
Stars
Language
License
Activity
6001
smeijer/leaflet-geosearch
A geocoding/address-lookup library supporting various api providers.
★ 1.1k
TypeScript
MIT
Active
6002
marmelab/shadcn-admin-kit
Component kit to build your Admin app with shadcn/ui
★ 1.1k
TypeScript
MIT
Active
6003
axe-me/vite-plugin-node
Vite plugin to run your node dev server with HMR!
★ 1.1k
TypeScript
—
Slowing
6004
Jannchie/anichart.js
Easily create data visualization animation videos
★ 1.1k
TypeScript
MIT
Stale
6005
gemini-cli-extensions/nanobanana
★ 1.1k
TypeScript
Apache-2.0
Slowing
6006
lukasoppermann/design-tokens
🎨 Figma plugin to export design tokens to json in an amazon style dictionary compatible format.
★ 1.1k
TypeScript
MIT
Slowing
6007
Moekotori/ECHO
The Bit-Perfect Bridge to Your Sonic Multiverse.
★ 1.1k
TypeScript
AGPL-3.0
Active
6008
TanStack/tanstack.com
The marketing and docs site for all TanStack projects
★ 1.1k
TypeScript
—
Active
6009
snuffyDev/Beatbump
Alternative YouTube Music frontend built with Svelte/SvelteKit 🎧
★ 1.1k
TypeScript
AGPL-3.0
Archived
6010
dwyl/aws-sdk-mock
:rainbow: AWSomocks for Javascript/Node.js aws-sdk tested, documented & maintained. Contributions welcome!
★ 1.1k
TypeScript
Apache-2.0
Active
6011
RafalWilinski/telegram-chatgpt-concierge-bot
Interact with OpenAI's ChatGPT via Telegram and Voice.
★ 1.1k
TypeScript
—
Stale
6012
strapi/nextjs-corporate-starter
Strapi Demo application for Corporate Websites using Next.js
★ 1.1k
TypeScript
MIT
Archived
6013
iluobei/miaomiaowu
Clash配置订阅管理工具,支持节点管理、生成订阅、导入外部订阅节点、聚合流量、聚合订阅等功能。
★ 1.1k
TypeScript
—
Active
6014
fastify/fastify-vite
Fastify plugin for Vite integration
★ 1.1k
TypeScript
MIT
Active
6015
vue-stripe/vue-stripe
Stripe Elements and Checkout as Vue components
★ 1.1k
TypeScript
MIT
Active
6016
wuba/Picasso
一款UI自动生成代码插件,提供UI自动生成代码全流程解决方案。
★ 1.1k
TypeScript
MIT
Active
6017
reladraw/reladraw
★ 1.1k
TypeScript
Apache-2.0
Active
6018
alfg/ffmpeg-commander
A web-based GUI for quickly generating common FFmpeg command-line operations.
★ 1.1k
TypeScript
MIT
Active
6019
rango-exchange/rango-client
Rango Exchange Widget & Wallets Library
★ 1.1k
TypeScript
Apache-2.0
Active
6020
darula-hpp/shimmer-from-structure
A structure-aware skeleton loader that mirrors your rendered UI at runtime. Zero layout duplication. Built for modern frameworks.
★ 1.1k
TypeScript
MIT
Active
6021
EveryInc/proof-sdk
Proof SDK: open-source collaborative editor, provenance model, and agent HTTP bridge
★ 1.1k
TypeScript
MIT
Active
6022
electron/rebuild
Package to rebuild native Node.js modules against the currently installed Electron version
★ 1.1k
TypeScript
MIT
Active
6023
spruceid/siwe
Sign-In with Ethereum library
★ 1.1k
TypeScript
Apache-2.0
Stale
6024
mlc-ai/web-llm-chat
Chat with AI large language models running natively in your browser. Enjoy private, server-free, seamless AI conversations.
★ 1.1k
TypeScript
Apache-2.0
Slowing
6025
romannurik/SlidesCodeHighlighter
A little web app that helps you copy+paste syntax-highlighted code into slide decks.
★ 1.1k
TypeScript
Apache-2.0
Slowing
6026
TypeStrong/atom-typescript
The only TypeScript package you will ever need
★ 1.1k
TypeScript
MIT
Stale
6027
clucraft/PriceGhost
A self-hosted price tracking application that monitors product prices from any website.
★ 1.1k
TypeScript
—
Slowing
6028
tegnike/aituber-kit
A web application for chatting with AI characters that anyone can easily set up and deploy.
★ 1.1k
TypeScript
Other
Active
6029
aave/aave-v3-core
This repository contains the core smart contracts of the Aave V3 protocol.
★ 1.1k
TypeScript
Other
Archived
6030
nkzw-tech/fate
A modern data client for the web.
★ 1.1k
TypeScript
MIT
Active
6031
stevenlei/spacingjs
A JavaScript utility for measuring the spacing between elements on webpage.
★ 1.1k
TypeScript
MIT
Stale
6032
kitlangton/ghui
A GitHub TUI
★ 1.1k
TypeScript
MIT
Active
6033
downthemall/downthemall
The DownThemAll! WebExtension
★ 1.1k
TypeScript
Other
Active
6034
m31coding/fuzzy-search
A fast, accurate and multilingual fuzzy search library for the frontend.
★ 1.1k
TypeScript
MIT
Slowing
6035
iFurySt/RedNote-MCP
🚀MCP server for accessing RedNote(XiaoHongShu, xhs).
★ 1.1k
TypeScript
MIT
Stale
6036
pastelsky/tsdocs
Browse type documentation for JS libraries
★ 1.1k
TypeScript
MIT
Stale
6037
axflow/axflow
The TypeScript framework for AI development
★ 1.1k
TypeScript
MIT
Stale
6038
Scthe/nanite-webgpu
UE5's Nanite implementation using WebGPU. Includes the meshlet LOD hierarchy, software rasterizer and billboard impostors. Culling on both p
★ 1.1k
TypeScript
MIT
Slowing
6039
prettymuchbryce/http-status-codes
Constants enumerating the HTTP status codes. All status codes defined in RFC1945 (HTTP/1.0, RFC2616 (HTTP/1.1), and RFC2518 (WebDAV) are sup
★ 1.1k
TypeScript
MIT
Stale
6040
bring-shrubbery/SVG-to-SwiftUI
SVG to SwiftUI Compiler
★ 1.1k
TypeScript
Apache-2.0
Active
6041
BenLorantfy/nestjs-zod
All NestJS + Zod utilities you need
★ 1.1k
TypeScript
MIT
Active
6042
mui/pigment-css
⚠️ 𝐀𝐥𝐩𝐡𝐚 𝐩𝐡𝐚𝐬𝐞, currently, on hold. Pigment CSS is a zero-runtime CSS-in-JS library that extracts the colocated styles to their own CSS file
★ 1.1k
TypeScript
MIT
Active
6043
AnnaSuSu/TechSpar
一个持续进化的面试训练系统。在线体验地址:https://techspar.cn
★ 1.1k
TypeScript
AGPL-3.0
Active
6044
yuanqing/create-figma-plugin
:battery: The comprehensive toolkit for developing plugins and widgets for Figma
★ 1.1k
TypeScript
MIT
Slowing
6045
colinhacks/zshy
🐒 Bundler-free build tool for TypeScript libraries. Powered by tsc.
★ 1.1k
TypeScript
MIT
Active
6046
shuaiplus/inkstone
A self-hosted Markdown notebook that runs entirely on Cloudflare Workers.
★ 1.1k
TypeScript
Other
Active
6047
goodnight000/api-anything
Turn any website into an API your agent can call. Learns from the site's own frontend, heals itself when the site changes.
★ 1.1k
TypeScript
MIT
Active
6048
graphql-hive/SOFA
The best way to create REST APIs - Generate RESTful APIs from your GraphQL Server
★ 1.1k
TypeScript
MIT
Active
6049
BabylonJS/Editor
Community managed visual editor for Babylon.js
★ 1.1k
TypeScript
Apache-2.0
Active
6050
davidyaha/graphql-redis-subscriptions
A graphql subscriptions implementation using redis and apollo's graphql-subscriptions
★ 1.1k
TypeScript
MIT
Stale
←
1
…
119
120
121
122
123
…
136
→