SSealbook
Sealbook / Open source / Web & backend frameworks

Top open-source web & backend frameworks on GitHub

4,712 repositories with 1,000+ stars, ranked by stars. Leading: public-apis, superpowers, vue.

RepositoryStarsLanguageLicenseActivity
4251fixie-ai/ai-jsxThe AI Application Framework for Javascript★ 1.1kTypeScriptMITStale
4252ubisoft/massgateMassgate is the online backend server for the Massive Entertainment game World in Conflict, and is now open-source to make it possible for a★ 1.1kC++GPL-2.0Archived
4253genotrance/pxAn HTTP proxy server to automatically authenticate through an NTLM proxy★ 1.1kPythonMITActive
4254sindresorhus/terminal-imageDisplay images in the terminal★ 1.1kJavaScriptMITSlowing
4255abcminiuser/lufaLUFA - the Lightweight USB Framework for AVRs.★ 1.1kC—Slowing
4256distribyted/distribytedTorrent client with HTTP, fuse, and WebDAV interfaces. Start exploring your torrent files right away, even zip, rar, or 7zip archive content★ 1.1kGoGPL-3.0Slowing
4257Shopify/cli-uiCLI tooling framework with simple interactive widgets★ 1.1kRubyMITActive
4258ufna/VaRestREST API plugin for Unreal Engine 4 - we love restfull backend and JSON communications!★ 1.1kC++MITArchived
4259YunYouJun/valaxy🌌 Next Generation Static Blog Framework (Beta) 下一代静态博客框架(支持页面/配置热重载)★ 1.1kTypeScriptMITActive
4260uncomplicate/neanderthalFast Clojure Matrix Library★ 1.1kClojureEPL-1.0Active
4261shanmiteko/LotteryAutoScriptBili动态抽奖助手★ 1.1kJavaScriptGPL-3.0Slowing
4262victorb/trymodule➰ It's never been easier to try nodejs modules!★ 1.1kJavaScript—Stale
4263amatsuda/active_decoratorORM agnostic truly Object-Oriented view helper for Rails 4, 5, 6, 7, and 8★ 1.1kRubyMITActive
4264NicolasPetton/IndiumA JavaScript development environment for Emacs★ 1.1kEmacs LispGPL-3.0Archived
4265openwisp/django-rest-framework-gisGeographic add-ons for Django REST Framework. Maintained by the OpenWISP Project.★ 1.1kPythonMITActive
4266alibaba/dawn:sunrise: Dawn is a lightweight task management and build tool for front-end and nodejs. ★ 1.1kJavaScriptMITStale
4267Almeros/android-gesture-detectorsGesture detector framework for multitouch handling on Android, based on Android's ScaleGestureDetector★ 1.1kJavaOtherStale
4268tumblr/colossusI/O and Microservice library for Scala★ 1.1kScalaApache-2.0Stale
4269Lawouach/WebSocket-for-PythonWebSocket client and server library for Python 2 and 3 as well as PyPy (ws4py 0.5.1)★ 1.1kPythonBSD-3-ClauseActive
4270tmcw/docboxREST API documentation generator★ 1.1kCSSISCStale
4271dji-sdk/Mobile-SDK-AndroidDJI Mobile SDK for Android: http://developer.dji.com/mobile-sdk/★ 1.1kJavaOtherStale
4272dwightwatson/rememberableQuery caching for Laravel★ 1.1kPHPMITSlowing
4273metosin/compojure-apiSweet web apis with Compojure & Swagger★ 1.1kClojureEPL-1.0Stale
4274palkan/isolatorDetect non-atomic interactions within DB transactions★ 1.1kRubyMITActive
4275bramus/routerA lightweight and simple object oriented PHP Router★ 1.1kPHPMITStale
4276exAspArk/batch-loader:zap: Powerful tool for avoiding N+1 DB or HTTP queries★ 1.1kRubyMITSlowing
4277BigShow1949/BigShow1949iOS教学/各类知识点总结:运行时/贝塞尔曲线/水纹/粒子发射器/核心动画/渐变色/网络请求/按钮/标签/视图布局/视图效果/文字视图/表情键盘/旋转动画/2048/网易/微信/猿题库/阿里巴巴/设计模式/数据持久化/多次点击按钮/微信注册按钮/展开按钮/跑马灯/闪烁文字/球形滚★ 1.1kObjective-C—Stale
4278146BC/StyleKitA powerful & easy to use styling framework written in Swift★ 1.1kSwiftMITStale
4279huacnlee/rails-settings-cachedGlobal settings for your Rails application.★ 1.1kRubyOtherActive
4280microsoft/WindowsCompositionSamplesThe Windows Composition Samples have moved here: https://github.com/microsoft/WindowsAppSDK-Samples/tree/main/Samples/SceneGraph★ 1.1kC#MITArchived
4281wrapp-archive/floatlabelededittextFloating hint from edit text - inspired by Matt D. Smith's design: http://dribbble.com/shots/1254439--GIF-Mobile-Form-Interaction?list=users★ 1.1kJava—Stale
4282planetscale/vtprotobufA Protocol Buffers compiler that generates optimized marshaling & unmarshaling Go code for ProtoBuf APIv2★ 1.1kGoBSD-3-ClauseSlowing
4283Flowframe/laravel-trendGenerate trends for your models. Easily generate charts or reports.★ 1.1kPHPMITSlowing
4284avwo/whistle-clientHTTP, HTTP2, HTTPS, Websocket debugging proxy client★ 1.1kJavaScriptMITActive
4285haywire/haywireHaywire is an asynchronous HTTP server framework written in C that's built using the event loop based libuv platform layer that node.js is b★ 1.1kCApache-2.0Stale
4286onevcat/HedwigSend email to any SMTP server like a boss, in Swift and cross-platform★ 1.1kSwiftMITSlowing
4287prettymuchbryce/http-status-codesConstants enumerating the HTTP status codes. All status codes defined in RFC1945 (HTTP/1.0, RFC2616 (HTTP/1.1), and RFC2518 (WebDAV) are sup★ 1.1kTypeScriptMITStale
4288luckybilly/AutoRegister基于字节码插桩,在Android中实现跨module自动注册的gradle插件,可用于模块解耦。已应用于ARouter和CC★ 1.1kGroovyApache-2.0Stale
4289gecche/laravel-multidomainA Laravel extension for using a laravel application on a multi domain setting★ 1.1kPHPMITSlowing
4290ging/social_streamA framework for building distributed social network websites★ 1.1kRubyMITStale
4291teest114514/chatlog_alpha原 [chatlog]项目(一个微信数据库解密读取及提供mcp服务、http服务的开源软件),现已支持通过微信clawbot接口推送消息,可以实时转发全部或指定消息到clawbot★ 1.1k——Active
4292BenLorantfy/nestjs-zodAll NestJS + Zod utilities you need★ 1.1kTypeScriptMITActive
4293pods-framework/podsThe Pods Framework is a Content Development Framework for WordPress - It lets you create and extend content types that can be used for any p★ 1.1kPHPGPL-2.0Active
4294apache/nanoNano is now part of Apache CouchDB. Repo moved to https://GitHub.com/apache/couchdb-nano★ 1.1kJavaScriptOtherArchived
4295jonikorpi/FramelessThe spiritual successor to Less Framework★ 1.1kCSS—Archived
4296AnnaSuSu/TechSpar一个持续进化的面试训练系统。在线体验地址:https://techspar.cn★ 1.1kTypeScriptAGPL-3.0Active
4297gautema/CQRSliteA lightweight framework to help creating CQRS and Eventsourcing applications in C#★ 1.1kC#OtherActive
4298thuml/TimesNetAbout Code release for "TimesNet: Temporal 2D-Variation Modeling for General Time Series Analysis" (ICLR 2023), https://openreview.net/pdf?i★ 1.1k—MITStale
4299dmstr/yii2-adminlte-assetAdminLTE Asset Bundle for Backend Theme in Yii2 Framework★ 1.1kPHP—Slowing
4300graphql-hive/SOFAThe best way to create REST APIs - Generate RESTful APIs from your GraphQL Server★ 1.1kTypeScriptMITActive